Jump to content

Archived

This topic is now archived and is closed to further replies.

seattleite

Duel Portal Glitches Thread

Recommended Posts

You can post any glitches you found. Please make sure to include the steps you took to reproduce it, and error details, if any.

 

 

Card Submitter:

 

[spoiler=Uploading from YCM cuts off the last letter of the card's set name (i.e. Special Filter)]

Discovered: 2/10/15 (Yes it was earlier than this, but cba to check)

Status: Working on it

Workarounds: After generating, edit the generated code before submitted.

 

[/spoiler]

 

 

Deck Editor:

 

[spoiler=Cards in the deck editor sometimes take on a random image]

Discovered: 2/12/15

Status: Inactive

 

There can be several causes for this, none of which hampers gameplay. When you flip through cards too fast in the deck editor, sometimes updating the image lags behind, and it gets confused. Workaround: Just click another card, then re-click your card. If this is the issue, the card's image will be restored.

 

Image caching was an issue, but maybe resolved?? (5.055)

 

[/spoiler]

 

 

Duel Field:

[spoiler=Face-down cards sometimes persist as facedown in the Graveyard, or in the Deck when used in a previous duel]

Discovered: 2/12/15

Status: Working on it

Workarounds: Banish the card in the Grave, then return it to the Grave.

[/spoiler]

 

[spoiler=Changing counters on a card sometimes shows in log as the Field Spell, and '0 counters']

Discovered: 2/14/15

Status: Working on it

Workarounds: Click the card in question to see how many counters it has.

[/spoiler]

 

[spoiler=Opponent's cards sometimes don't show up, and there's no information in the log]

Discovered: 2/12/15

Status: Low-priority

 

A poor internet connection, on either player's side can cause this. Possible feature where failed connections, once re-established, can re-send the data that was lost, however, it's not a high-priority now. Almost all of Duel Portal requires a good internet connection anyway.

 

Sometimes if it's a card on the field, flipping it face-down then up again will clear up the issue.

 

[/spoiler]

 

[spoiler=Match duels say 'Connection OK' multiple times, during the course of the duel.]

Discovered: 2/14/15

Status: Working on it

Workarounds: Ignore.

[/spoiler]

 

[spoiler=Long messages run past the screen in the log]

Discovered: 2/14/15

Status: Working on it

Workarounds: Break up your messages.

[/spoiler]

 

[spoiler=Cards, buttons etc. can't be interacted with in the middle of a duel]

Discovered: 2/20/15

Status: Need more information

Workarounds: None

 

This happens rarely, but the cause is still unknown. Unfortunately nothing can be done but to reload the site.

[/spoiler]

 

Lobby:

 

 

Login Page:

 

 

Mail:

 

Other:

 

 

 

 

 

Resolved issues:

 

[spoiler=Newly created/edited cards sometimes are tuners when they aren't supposed to be]

Discovered: 2/12/15 ?

Status: Resolved?? (5.055)

Workarounds: Try editing the card again.

[/spoiler]

 

 

[spoiler=Taking a monster off the field when it has two or more Xyz materials creates an error]

Discovered: 2/10/15 (Yes it was earlier than this, but cba to check)

Status: Resolved

Workarounds: Detach xyz materials so there's no more than 1 before sending to Graveyard, etc.

 

[/spoiler]

 

[spoiler=Starting another game in a match shows a field spell in play, even if never played it yet that game. ]

Discovered: 2/14/15

Status: Resolved

Workarounds: Click the activation button from right clicking the card and click the error ok screen.

[/spoiler]

Share this post


Link to post
Share on other sites

Did what you say and stickied this thread over Sakura's.

 

Edit: Oh, also, regarding my issue, I think I know the reason now.

 

It's due to the odd behavior of my connection, for the most part. I've tried around some stuffs, and all of those points to that being the issue about me being unable to connect.

 

Sorry for bugging you too much regarding this problem, Sea.

Share this post


Link to post
Share on other sites

Might be an old thing, but basically for self-testing reasons.

Sometimes the opponent's cards do not show up on the field, nor does the log update to say what they did.

 

There's also the lack of picture stuff lately, but I believe that was already dealt with earlier.

 

 

Also Nai, I would've locked my version of this thread myself; had my net not been shitty at the time.

Share this post


Link to post
Share on other sites

Me and some other users had a problem where some newly created or edited monsters randomly appeared as tuners, even though they were never set to be one in the creator. This is pretty minor as it can just be fixed by re-editing, but it's a bug nontheless.

Share this post


Link to post
Share on other sites

bug: some times cards are sent to the graveyard face-down [Displaying as "face-down card" and not having lore]. I only recall this happening when sent from the field. It seems to be random and not related to the card's face-up/face-down position before it hit the gy.

(I've also seen them be displayed face-down to the owner face-down while in hand or displayed in the deck search menu face-down, but that's less of an issue since the opponent doesn't see those screens.)

 

workaround: Banish the card, then send it back to the gy and it should be face-up after that.

Share this post


Link to post
Share on other sites

Thank you for the bug reports, updated.

 

 

 

Sorry for bugging you too much regarding this problem, Sea.

 

It's all good in the hood

 

Me and some other users had a problem where some newly created or edited monsters randomly appeared as tuners, even though they were never set to be one in the creator. This is pretty minor as it can just be fixed by re-editing, but it's a bug nontheless.

 

I remember this from a while ago, but I just barely changed the layout. Has it popped up recently?

Share this post


Link to post
Share on other sites

The face-down Bug is not just with cards that are sent to the graveyard. I think it happens with cards that were used, set or activated in a previous duel - it happened to both me and Grandmaster of Darkness like that. Cards with the same name as cards that were used in the previous duel are also affected as it seems, for example all my Fiendish Chains and Vanity's Emptiness were flipped even when in the Deck.

Share this post


Link to post
Share on other sites

For the Incorrect images issue, you didn't mention the work-around of erasing your browser cache, then re-loading the web browser and logging into DP. Perhaps a way to fix it is by eliminating the cache functionality until the issue is resolved? I'm certain there are ways to do that.

 

Here's a small list of unmentioned bugs I've encountered:

*Whenever there are counters placed on a card and displayed in the chat, it always refers to my Field Spell, then always says 0 counters (This is especially prevalent when fighting counter-heavy decks, like "Crags").

*When I start another game in a match, it shows I have my field spell in play, even if I never played it yet that game. I resolve it by clicking the activation button from right clicking the card, clicking the error ok screen, then presume to activate the card again. It doesn't cause any connectivity issues from my play testing, just a little annoying.

*When you post a long message, it will eventually cut off and continue going horizontally to the right, meaning you have to scroll right using the horizontal scroll bar. Maybe this could be alleviated by limiting the amount of words on the chat box.

*When I start a match, since the update, it will say "Connection OK" multiple times over the course of the game, or it will have "Connection OK" posted on the duel chat box in multiples before the game begins.

 

I'll post more when I remember/find more later. I bet more issues will crop up after I begin the tourney this Monday.

Share this post


Link to post
Share on other sites

Earlier today, the greatest bug in the history of Duel Portal happened. I was dueling Torpy (Bagel Character), and Triky was dueling Self-Destruct Button. It's a pretty boring duel, Mikos vs Trains and Trains were reking me because they're OP as hell.

 

BUT SUDDENLY!

 

After some weird combination of events, somehow we could see each other's duel. The duel textbox stuff was showing the words from both our duels, and according to Self-Destruct Hiei actually showed up on their duel. I'm not sure what actually triggered this, but it happened right after Torpy summoned Shay Steamer and I chained Book of Moon. I don't think this will happen ever again, but please don't fix this because it's fucking hilarious.

Share this post


Link to post
Share on other sites

Earlier today, the greatest bug in the history of Duel Portal happened. I was dueling Torpy (Bagel Character), and Triky was dueling Self-Destruct Button. It's a pretty boring duel, Mikos vs Trains and Trains were reking me because they're OP as hell.

 

BUT SUDDENLY!

 

After some weird combination of events, somehow we could see each other's duel. The duel textbox stuff was showing the words from both our duels, and according to Self-Destruct Hiei actually showed up on their duel. I'm not sure what actually triggered this, but it happened right after Torpy summoned Shay Steamer and I chained Book of Moon. I don't think this will happen ever again, but please don't fix this because it's f***ing hilarious.

This happened to me once before, though it was completely limited to the textbox.

 

Also, I prefer the term "Railroaders" when referring to my cards.

Share this post


Link to post
Share on other sites

For the Incorrect images issue, you didn't mention the work-around of erasing your browser cache, then re-loading the web browser and logging into DP. Perhaps a way to fix it is by eliminating the cache functionality until the issue is resolved? I'm certain there are ways to do that.

 

You're right, thanks.

 

Send to graveyard sometimes adds to hand.

 

Since the two buttons are right next to each other, and I've never heard of this issue before, I'm going to wait and see if more people can confirm.

 

Earlier today, the greatest bug in the history of Duel Portal happened. I was dueling Torpy (Bagel Character), and Triky was dueling Self-Destruct Button. It's a pretty boring duel, Mikos vs Trains and Trains were reking me because they're OP as hell.

 

BUT SUDDENLY!

 

After some weird combination of events, somehow we could see each other's duel. The duel textbox stuff was showing the words from both our duels, and according to Self-Destruct Hiei actually showed up on their duel. I'm not sure what actually triggered this, but it happened right after Torpy summoned Shay Steamer and I chained Book of Moon. I don't think this will happen ever again, but please don't fix this because it's f***ing hilarious.

 

I.... have no words. :P

 

 

 

During I duel I just did:

 

I control number 99 with 3 materials and my opponent plays creature swap. His monster ends up in the zone where 99 was

 

and when I send his monster to the gy, 99's materials go with it.

 

That's the norm - it's just in case you actually WANT your opponent's cards in your graveyard (hey, there's probably some cc creator that's done it) :)

Share this post


Link to post
Share on other sites

After a usual crash I somehow can't see online list, chat, host nor joining, but from what I've seen ppl seemed to dueling normally. Based on Nai's case this maybe my own connection's problem, just thought that I could somewhat report.

 

Edit: Changing user and removing cache not worked, this's more like a problem on my end.

Share this post


Link to post
Share on other sites

After a usual crash I somehow can't see online list, chat, host nor joining, but from what I've seen ppl seemed to dueling normally. Based on Nai's case this maybe my own connection's problem, just thought that I could somewhat report.

 

Edit: Changing user and removing cache not worked, this's more like a problem on my end.

 

no, it's not just you. I can't seem to see the online list either. I can see people dueling but nothing shows up when I watch their duel

Share this post


Link to post
Share on other sites

When I was dueling for Tourney, on the 3rd game, I couldn't get anything open. It all stayed completely frozen, and I couldn't move my cards at all. When I used the UI interface buttons, it showed in text, and my opponent could see it, but I had no control over the cards. My opponent and my board state completely froze, and I had to forfeit. This glitch never happened before the most recent update, could you please look into it?

Share this post


Link to post
Share on other sites

New version released, hopefully dealing with the Tuners and Image Caching bugs.

 

This is the first of many glitch fixes, I'm gonna tackle some more tomorrow.

 

 

When I was dueling for Tourney, on the 3rd game, I couldn't get anything open. It all stayed completely frozen, and I couldn't move my cards at all. When I used the UI interface buttons, it showed in text, and my opponent could see it, but I had no control over the cards. My opponent and  board state completely froze, and I had to forfeit. This glitch never happened before the most recent update, could you please look into it?

 

It's happened before, but it's rare. I'll mark it down, not sure what the cause is yet. Thanks.

Share this post


Link to post
Share on other sites
[Async_ExceptionOccurred]
Arguments: 
Debugging resource strings are unavailable. Often the key and arguments provide sufficient information to diagnose the problem. See http://go.microsoft.com/fwlink/?linkid=106663&Version=5.1.30317.00&File=System.dll&Key=Async_ExceptionOccurred
 
   at System.ComponentModel.AsyncCompletedEventArgs.RaiseExceptionIfNecessary()
   at DuelPortalCS.SQLReference.populateSQLCompletedEventArgs.get_Result()
   at DuelPortalCS.Home.sqlFile_Get(Object sender, populateSQLCompletedEventArgs e)
   at DuelPortalCS.SQLReference.Service1ConsoleClient.OnpopulateSQLCompleted(Object state)


That keeps popping up on my screen when I try to log in. At one point I somehow bypassed it, but all of my decks were for some reason emptied out. Luckily I was able to get through the one tournament match without the use of pictures...sad face. 

Now I have tried clearing cache but that doesn't seem to work. 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...